Replacement Tokens in Maintenance Plans

Last Post 02 Aug 2012 11:10 AM by mfields. 0 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
mfields
New Member
New Member

--
02 Aug 2012 11:10 AM
Hi all,

I'm trying to use replacement tokens in my Maintenance plan in either T-SQL Statement task or
Notify Operator task but every time I insert any of the replacement token marker the job blows up. I have one step in the test job:

PRINT $(ESCAPE_ NONE(JOBID))

I pulled this directly off the Microsoft documentation page:

http://msdn.microsoft.com/en-us/lib...75575.aspx


Here's the error I'm getting:

Message
Executed as user: CENTRIC\mfields. Microsoft (R) SQL Server Execute Package Utility Version 11.0.2100.60 for 64-bit Copyright (C) Microsoft Corporation. All rights reserved. Started: 1:07:54 PM Progress: 2012-08-02 13:08:00.55 Source: {94B0B6A4-EE2B-443B-9470-DEA697E4EE9B} Executing query "DECLARE @Guid UNIQUEIDENTIFIER EXECUTE msdb..sp...".: 100% complete End Progress Error: 2012-08-02 13:08:01.75 Code: 0xC002F210 Source: Execute T-SQL Statement Task Execute SQL Task Description: Executing the query "" failed with the following error: "". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly. End Error Warning: 2012-08-02 13:08:01.78 Code: 0x80019002 Source: Subplan_1 Description: SSIS Warning Code DTS_W_MAXIMUMERRORCOUNTREACHED. The Execution method succeeded, but the number of errors raised (1) reached the maximum allowed (1); resulting in failure. This occurs when the number of errors reaches the number specified in MaximumErrorCount. Change the MaximumErrorCount or fix the errors. End Warning DTExec: The package execution returned DTSER_FAILURE (1). Started: 1:07:54 PM Finished: 1:08:02 PM Elapsed: 8.393 seconds. The package execution failed. The step failed.

I've followed the directions in the documentation and turned on the agent job replacement token feature but continue to recieve this error no matter what marker I use. I've even used the trace utility to try to capture more detail but I only get the "Executing the query "" failed..." error again.

Any suggestions would be greatly appreciated in either fixing or helping me debug this problem.

Mike F.
St. Louis, MO
You are not authorized to post a reply.

Acceptable Use Policy