AppDomain memory pressure

Last Post 01 Nov 2011 04:57 AM by gunneyk. 6 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
ctseah
New Member
New Member

--
11 Oct 2011 07:49 PM
Hi,

I have been getting this message during 02:00hr and 04:00hr

AppDomain 29 (mydbfin.dbo[runtime].28) is marked for unload due to memory pressure.
AppDomain 29 (mydbfin.dbo[runtime].28) unloaded.
AppDomain 30 (mydbfin.dbo[runtime].29) created

I am wondering why there is such message during this time slot.
There is no user accessing the database and what could trigger this message in my SQL server logs.

I am currently on SQL Server 2005 sp3.

Thanks in advance.

Thanks &
Regards
ctseah
New Member
New Member

--
17 Oct 2011 11:20 PM
Hi,

Anybody got any idea how to resolve this issue ?

The physical memory in the box is about 2GB.

I have set the max memory in SQL server to use upto a maximum of 1GB to prevent SQL server from using too much memory.
Before that SQL server could use the max amount of memory as it was left to the default.

But setting max memory configuratioon to limit it to 1GB still could not resolve the problem. But the error did stop for 2 - 3 days, now it has re-surfaced again.

Thanks and hope somebody can shed some light in this issue.

Thanks in advance.

regards
gunneyk
New Member
New Member

--
18 Oct 2011 12:06 PM
It sounds like to me that you are using the CLR. Do you have CLR functions or stored procedures? Only 2GB total. That's barely enough memory to run the OS these days much less SQL Server. Does task manager show any otehr apps using a lot of memory?
ctseah
New Member
New Member

--
25 Oct 2011 01:12 AM

Hi ,

I am not sure whether I have CLR running in the system. How do I check it ?
I have limit my max_memory parameter to 900MB, but problem still there.
Yes this server is low on physical memory.

Thanks in advance.

regards
gunneyk
New Member
New Member

--
25 Oct 2011 04:55 AM
Well for one you can look to see if the CLR is even enabled. You can do that by selecting * from sys.configurations and see if the CLR Enabled option is turned on.
ctseah
New Member
New Member

--
01 Nov 2011 12:45 AM
Hi,

Yes CLR is enabled in my system after checking.
Anything I can do to prevent this error ?
Is there any harm if I leave it as it is ?
So far there is no complaint from users when there is such an occurrence. Wonder whether when such event happened, is the database still accessible by the application ?

Regards
gunneyk
New Member
New Member

--
01 Nov 2011 04:57 AM
Well you don't want to disable it if someone is using the CLR for something or you will break it. The bottom line is you probably need more memory on the box itself. 2GB is pretty low for SQL Server and especially if you are using the CLR which can use additional memory than SQL Server itself.
You are not authorized to post a reply.

Acceptable Use Policy