Database mail issue

Last Post 04 Mar 2011 09:08 AM by PaulMcKibben. 8 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
PaulMcKibben
New Member
New Member

--
17 Feb 2011 12:07 PM
Configured DB Mail, I believe, successfully.  I say that because there were no issues in the configuration, but test emails don't get sent.

Sending test emails from the GUI, queues them up, but they stay in an unsent status until I manually execute databasemail90. 

I have several SQL 2005 servers that are in the same situation so I will, for now, only comment on one.

I am able to telnet to port 25 on the smtp server from the server in question, service broker is enabled, and the profile is a public profile.  When I execute sp_helprolemember on DatabaseMailUserRole, it returns an empty set, as it does for a SQL server that mail functions on.  The logging is set to verbose, and the Database Mail process is started and the activation is successful. 

The email is not recieved though. 

Any help in resolving this is greatly appreciated.

rm
New Member
New Member

--
18 Feb 2011 05:48 AM
Sysadmin can send db mail even is not member of DatabaseMailUserRole. How did you set smtp authentication in the profile?
PaulMcKibben
New Member
New Member

--
18 Feb 2011 09:05 AM
Anonymous authentication
rm
New Member
New Member

--
18 Feb 2011 10:16 AM
Tried with other options?
PaulMcKibben
New Member
New Member

--
18 Feb 2011 10:37 AM
No, but of approximately 70 servers, I would say that there are 5 that are performing as described above.
rm
New Member
New Member

--
18 Feb 2011 12:12 PM
Do they have same sql2k5 sp?
PaulMcKibben
New Member
New Member

--
18 Feb 2011 12:25 PM
Yes, they are all SP3
PaulMcKibben
New Member
New Member

--
22 Feb 2011 12:19 PM
Focusing on one of the servers:

1. It is SQL 2005 SP3
2. Service broker in msdb is enabled
3. We are using port 25 on the smtp server.
4. I can telnet to port 25 on the smtp server from the server.
5. The enable mail profile checkbox is checked and Database Mail is selected.
6. SQL Server Agent was restarted.
7. The only things in the database mail log are 2 Activation Successful messages when I try to send a test mail.

I am out of ideas and would appreciate any suggestions.

Thank you.
PaulMcKibben
New Member
New Member

--
04 Mar 2011 09:08 AM
The reason for the DB Mail test email failure was the fact that the SQL Server service login user was not listed under Logins in SSMS.
You are not authorized to post a reply.

Acceptable Use Policy