Making Database mail working on Sql Server 2005 64 Bit window 2008 Clustered Environment

Last Post 02 Aug 2009 05:52 PM by Jiangxi. 2 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Jiangxi
New Member
New Member

--
01 Aug 2009 07:26 PM
Wondering anyone has successful experience to make database mail working on Sql Server 2005 64 Bit window 2008 Clustered Environment ?

Any input will be highly appreciated !

Jiangxi
New Member
New Member

--
02 Aug 2009 05:52 PM
Anything you did different with the 32 bit system , rm ?

We have all working fine on all 32 bit SQL Server 2005 cluster servers, but none of them working at 64 Bit window 2008 Clustered Environment.

All the mail are in the queue in "unsent" status, the problem really seems like SQL Server not able to run DataBaseMail90.exe external program to deliver the emals:

EXECUTE msdb.dbo.sysmail_help_queue_sp ;

results:

mail 34 NOTIFIED 2009-08-02 05:57:18.847 2009-08-02 05:57:18.873
status 0 INACTIVE 2009-08-02 06:14:06.543 2009-08-02 06:14:06.467


select * from sysmail_event_log;

results:

........
34 error 2009-08-01 15:05:00.853 Activation failure. NULL NULL NULL 2009-08-01 15:05:00.853 sa
35 error 2009-08-01 22:57:19.317 Activation failure. NULL NULL NULL 2009-08-01 22:57:19.317 sa

So, how am i able to let DB Mail to activate the DatabaseMail90. exe ?

I installed SQL Server 2005 SE plus SP3 on this 64bit windows 2008 EE , two nodes active/active cluster, i can see the DatabaseMail90.exe sitting at \MSSQL\Binn, and i actually put the virutal server name with virtual IP in host file on both nodes, still not able to get it going, any thoughts ? Thanks a bundle !

Jiangxi
New Member
New Member

--
03 Aug 2009 01:29 PM
which part cover the permissions, Gunneyk ? Can you please be more specific, appreciated .

Like i said, i did this db mail many many times without any issues, but just not working on the two nodes cluster server ( 64 bit windows 2008 ), installed as named instances and number static port numbers, we have four paired two nodes SQL Server 2005 plus SP3 servers, none of those instances datbase mail work, they are all the same problem --- mails sitting there with the status "unsent" in the queue, wondering did you really make it work at 64 bit windows cluster servers ? thanks.
You are not authorized to post a reply.

Acceptable Use Policy