Cannot Configure Report Server database connection

Last Post 04 Feb 2009 09:01 AM by Amber_Robertsona. 4 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Amber_Robertsona
New Member
New Member

--
03 Feb 2009 07:49 AM
Dear All, does anybody know how I can upgrade SQL 2005 Report Server database?
I am unable to configure Report Server database connection, I keep getting the warning "The database version (C.0.8.40) does not match your Reporting Services installation. You must upgrade your Reporting Services database". If I click Upgrade button this fails with a further warning message "ReportServicesConfigUI.WMIProvider.WMIProviderException: The version does not match a supported version." I am currently running the instance in SQL2005 Version 9.0.342 Standard Edition.

Any suggestions much appreciated.


Kind Regards
Amber
Amber_Robertsona
New Member
New Member

--
03 Feb 2009 08:40 AM
Hi Russell, thank you for the quick reply they are both on the same machine not sure if this helps, but I installed Reporting Services separately from the rest of SQL2005. I have also tried re-installing it a couple of times on the same machine. Also in the past I have applied SQL2005 patch to my local SQL2005 instance, could it be that the versions are different? If so how can I find out which version is which?


Regards
Amber
Amber_Robertsona
New Member
New Member

--
04 Feb 2009 01:40 AM
Hi Russell, it looks like SP2 has already been applied to my machine. Both SQL Server and Reporting Server are installed on the same machine but at different times. Does this make any difference? This isn't a production machine.
Amber_Robertsona
New Member
New Member

--
04 Feb 2009 09:01 AM
Hi Russell, after further investigation I have found that the instance that the Database Engine, where the Report Server and ReportServerTempDB, is Version 9.00.1399.06 at patch level 9.2.3042 but the Reporting Service is at version 9.00.1399.06 and patch level 9.00.1399.06. So I am going to see if I can apply patch on Reporting Services so the version match. I will let you know if this works.

Thank you for your help and advice.

Regards
Amber
Amber_Robertsona
New Member
New Member

--
05 Feb 2009 07:41 AM
Hi Russell, this problem is fixed. I upgraded all SQL2005 instances on my PC so they are same version and patch level and now all working well.

Thank you for your help

Regards
Amber
You are not authorized to post a reply.

Acceptable Use Policy