DBO Login name none

Last Post 12 Apr 2002 05:35 AM by satya. 3 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Shawn_SQL
New Member
New Member

--
12 Apr 2002 05:33 AM
I have a SQL 7.0 database Service pack 3 running on NT 4.0 with service pack 6a

From the server, you can click on ther Users section of the database and it displays a user of dbo, but the login name is blank. When you click on the dbo user and look at the propterties it displays Login Name: <none>

I have also tried to access this database from a client that is running SQL 2000 enterprise manager. I see the same results.

Does anyone know how this could have happened?
Does anyone know how the dbo account can be reassociated with a login name?

This is an enterprise wide database that is in production 24x7.
satya
New Member
New Member

--
12 Apr 2002 05:35 AM
Try SP_CHANGE_USERS_LOGIN with report clause and see any orphaned users are there in the database, also checkup with sysusers and syslogins for the sid match.

HTH
Shawn_SQL
New Member
New Member

--
12 Apr 2002 06:53 AM
The sp_change_users_login 'report' does not provide any additional information. It thinks that there are any orphaned accounts.

When you look at the sysuers in the database, the entry for the dbo account has a status of 14. There is not an entry in the sysxlogins for the dbo account.

Is there any other information that I can provide to help debug this problem?
Shawn_SQL
New Member
New Member

--
12 Apr 2002 08:09 AM
running a sp_changedbowner seems to have reassigned the dbo account login name to the new owner and fixed the problem.
You are not authorized to post a reply.

Acceptable Use Policy