HTTP status 401: Unauthorized Reporting Service

Last Post 05 Feb 2009 06:28 AM by SQL_Jr. 5 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
SQL_Jr
New Member
New Member

--
25 Jan 2009 03:00 AM
Hi, I'm getting this error when I hit a report on my server. Seems like a permission error, but I need to know exactly what's missing permission.

I set up a local account on the server which is local admin. I then used this for IIS. No good. PLease provide steps to resolve this frustrating error. TIA
SQL_Jr
New Member
New Member

--
25 Jan 2009 09:07 PM
hi, rm:

I'm pretty sure, but will you list the steps and details here? And. anything else I may have missed. Thx
SQL_Jr
New Member
New Member

--
26 Jan 2009 12:36 PM
rm: i'm sure this part's ok. I have a dev who is passing credential programatically using a sql account user name and pw. Is the requirement that this is a domain account?? B/c obviously I cannot add this account to the role as it is "not recognized username or group" (msg) THX

PLEASE REPLY ASAP! THX
SQL_Jr
New Member
New Member

--
04 Feb 2009 12:38 PM
russelb thx for reply - sorry for delay in response - but we thought we resolved it, but NOT SO.

For example, we try to connect to the SSRS via SSM, and get the HTTP: 401 unauthorize access error when connecting with a non-windows user (we select Basic Authentication)

However, when i Use my Windows credentials, connects - NO PROBLEM - Please Advise!
SQL_Jr
New Member
New Member

--
05 Feb 2009 06:28 AM
Yes! This is a MAJOR issue for us here. It may be a code issue with the .NET app trying to connect to the RS with a user/password - PLEASE ADVISE ON ADDITIONAL STEPS! Thx, again. Await reply.
SQL_Jr
New Member
New Member

--
05 Feb 2009 07:38 AM
RM!! Correction, I had Anonymous access enables at the top Default Site, but NOT on the Report and ReportServer virtual directories - now that I have done that, I was able to SUCCESSFULLY connect via SSM. Wtg on the dev to confirm if he can connect via .NET app. THX AGAIN!
You are not authorized to post a reply.

Acceptable Use Policy