Can't get mirroring to work - HELP!

Last Post 07 Jul 2008 07:40 AM by RSP_SQL. 3 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
RSP_SQL
New Member
New Member

--
03 Jul 2008 05:57 AM
I am frustrated now, after trying to set up mirroring between to servers in diff locations. I am able to ping each others server, register each server via SSM, and control the engine as well. I did everything to set up the endpoints, backup and restore db and log with no_recovery, etc. etc.

These servers ARE in different domains - I even tried to set up certificates, following this link: http://alan328.com/SQL2005_Database...rial.aspx.

When I click on start mirroring, it give me the msg: The server network address 'TCP://mymirrorserver.FQDN:5022' cannot be reached or does not exist - (yeah right!) Please advise what I could have missed!


(BTW: Suggestion: Make a new forum for Database Mirroring) THX!!
RSP_SQL
New Member
New Member

--
03 Jul 2008 08:34 AM
Thx rm for reply.

OK, I'm not 100% sure, but I can register them in EM both ways using NT auth -

UPDATE: I tried granting access on primary to mirror sql svc account (ie: domain\sqlservice) and it failed to create

The service accounts are different. The primary domain is .local. Would I grant cross-rights to each other's service acct - do they have to be same pw in that case?

ALso, firewall was opened to allow communication via 1433 both ways - what about the mirroring port 5022 - is there a special rule that needs to be applied too?

Please reply back soon and keep the thread going! MAny thanks, RM!
RSP_SQL
New Member
New Member

--
03 Jul 2008 10:03 AM
thx. but I tried granting the other one, and it failed. mydomain\sqlservice which is not local. any idea why?

FIREWALL is turned off on both sides.

both sql servers are started with their respective domain sql service accounts.

await follow-up tiar
RSP_SQL
New Member
New Member

--
07 Jul 2008 07:40 AM
GOT IT!

The issue in my case between two servers in non-trusted domains, was to use Certficates.

First, I needed to use port 7024 instead of 5022, and also add all the FQDN and IPs to the host files on all nodes. Then it worked!

THX
You are not authorized to post a reply.

Acceptable Use Policy