Need advice - Apply sp4 on failover cluster

Last Post 22 Jan 2006 06:03 PM by Vijay_SQL. 4 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Vijay_SQL
New Member
New Member

--
22 Jan 2006 02:39 PM
SP4 upgrade sql 2K cluster Active/passive - need info.
Hi ,
I am planning for sp4 install on sql2k cluster. We do not have a true microsoft cluster since
we use the Geo Cluster software solution as an alternative. Current sql server verion is sql2K-sp3a.
There are 2 publisher dbs on the server. Distribution db also resides on the same machine(I know it is a bad idea but
saving dollars is the reason we r using geo cluster software solution instead of true Microsoft certified solution).

The reason we r installing sp4 is to fix the "UMS scheduler hang" issue .

In case of any issues with sp4 during the install , i aim to use the roll back plan specified below.
I am hoping this is the fastest and cleanest possible roll back method.

1.Stop the sql server using EM prior to sp4 Install.
2.Make a copy of all the system and user db files and store them in a separate folder.
3.Start the sql server.
4.Install sp4. If everyting is OK fine else next steps.
5.Uninstall sqlserver using the sqlserver installation CD.
6.Install sqlserver.
7.Apply sp3a.
8.Reboot Nodes.
9.Stop sql server on Node1.
11.Copy the original user and system db (copied to separate folder in step 2) files to
their respective data folders.
12.Start the sql server.

Everything should be fine or will there be any problem.

Need your opinions regarding the plan. I am hoping the above plan will
allow me to avoid the process of restoring the system dbs , issues with replicated dbs and any
unexpected need for reconfiguring repliocation. Much thanks in advance .
Vijay_SQL
New Member
New Member

--
22 Jan 2006 06:03 PM
Thanks rm. A follow up question if u do not mind . Does sp4 really resolve the "UMS scheduler hung" issue. I have not seen any confirmation from anyone on various forums. Some even mentioned that they were thinking of rolling back to SP4 since it caused a host of new issues. The error we r trying to fix is as follows.

"Error: 17883, Severity: 1, State: 0

The Scheduler 0 appears to be hung. SPID 94, ECID 0, UMS Context 0x07E580C0"

According to microsoft resolution , sp4 will fix this issue . I am not really sure.
Vijay_SQL
New Member
New Member

--
22 Jan 2006 06:05 PM
Correction . "rolling back to SP4 " must be 'rolling back to SP3a" .
RSP_SQL
New Member
New Member

--
27 Jan 2006 10:14 AM
Vijay:

Definately check out SP4 fixes, as I am not sure that one is in there. I will tell you though that the UMS Hung Scheduler issue was a big one for one client's clustered infrastructure, and we needed to apply a HOT FIX to the cluster. So check the MS web-site for that hot fix as well. Hope that helps!
Vijay_SQL
New Member
New Member

--
30 Jan 2006 08:41 AM

Thanks RSP_SQL . I did verify that the fix does not exist in SP4 yet the SP4 documentation mentions it.
I have looked at the hotfixes . How bad was it for the client's clustered environment. Did the fix really solve the problem. I do not want to end up in a situation where i have to roll back to sp3a after running the system on sp4 for sometime. Much Thanks in advance.
You are not authorized to post a reply.

Acceptable Use Policy