Error with Enterprise Manager

Last Post 05 Jan 2005 11:09 AM by bigelectricmac. 7 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
bigelectricmac
New Member
New Member

--
05 Jan 2005 05:32 AM
Hi all,
I'm having a really wierd problem. I'm not sure if it is Database related, Server related or a problems with my SQL Tools. While trying to access a linked server, I am receiving the following error:
Server: Msg 7399, Level 16, State 1, Line 1
OLE DB provider 'IBMDADB2' reported an error. Access denied.
OLE DB error trace [OLE/DB Provider 'IBMDADB2' IUnknown:ueryInterface returned 0x80070005: Access denied.].

I am trying to access a DB2 database on our mainframe after setting it up as a linked server. This has been working in the past but has stopped for some reason.
I can login to the mainframe and run a query from within my 3270 session without problems. DB2 Connect is installed and I can run queries through Command Center. A program that I have written accesses the System Data source and can acces the mainframe without problems. It is only when I try and connect through my linked server that I receive an error.

Any help would be REALLY appreciated!

Chris G
bigelectricmac
New Member
New Member

--
05 Jan 2005 06:10 AM
No, I cannot. I receive the same error. Here is what I was trying to run:

Select * from openquery(DB2, 'Select polnum from Tablename')

"DB2" is the name of my Linked Server. If it makes a difference, I am running into this problem with MSDE.

Thanks,

Chris G
bigelectricmac
New Member
New Member

--
05 Jan 2005 06:37 AM
I setup the Linked Server using "IBM OLE DB Provider for DB2 Servers". I specified a datasource, DBP1, which I assume represents the system ODBC datasource I setup using the DB2 Connect client. The only other item I specified is on the Secutiry tab is "Be made using this security Context" where I specify a remote Login and password.

I have made no changes to the Server Options.

I should mention one other item. Initially I was getting a different error message which stated "INVALID PASSWORD". I am used to this error, because my mainframe password expires every 30 days. So every 30 days, I reset my mainframe password and update the linked server definition to reflect the new password. But this time, I received the error "Access Denied" instead of it working.

Thanks,

Chris G
bigelectricmac
New Member
New Member

--
05 Jan 2005 07:29 AM
I have tried that. I have also restarted the computer and checked WindowsUpdate. Do you think that uninstalling MSDE and the tools and then reinstalling them may correct the problem?
bigelectricmac
New Member
New Member

--
05 Jan 2005 07:36 AM
Yes, I have done that too.
bigelectricmac
New Member
New Member

--
05 Jan 2005 08:30 AM
OK I tried creating a new Linked Server using the Microsoft OLE DB for ODBC Driver. I supplied a value for the data source field, DBP1, and changed the Security for the connection to use the specific security context and provided my username and password.

I created the Linked Server, but I receive the same error as I did before. Ugh.

Thanks for all your help so far RM. Do you have any more ideas?

Chris G
bigelectricmac
New Member
New Member

--
05 Jan 2005 09:06 AM
I will check, but I dont think so. Which ports/traffic should I check?

I dont think that this could be the problem because I have a VB .NET application that I wrote which uses the same ODBC connection as my linked server. It is able to access the DB2 database.

This is frustrating....

Chris G
bigelectricmac
New Member
New Member

--
05 Jan 2005 11:09 AM
Just thought I would notify you of my results. I uninstalled MSDE and the SQL Tools. I rebooted and reinstalled MSDE and now my DB2 Linked server works. Not the most graceful way to resolve the issue, but it worked.

I get a different error when I try to use the OLE DB driver (Could not obtain Schema rowset?), but the ODBC Driver works!

Thanks for taking the time to help with my problem!

Chris G
You are not authorized to post a reply.

Acceptable Use Policy