Missing Data Sources

Last Post 07 Jun 2005 09:43 AM by sbuckingham. 4 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
sbuckingham
New Member
New Member

--
07 Jun 2005 03:46 AM
I am trying to import an Oracle 8.1.7 database into S2K using DTS's import utility. When asked for a data source from where I want the data to come from, I select 'Other ODBC' from the drop list and enter my connection data. However, when I press the "Next" button to move on, nothing happens. I thought as a workaround that I would then use Access so I imported the Oracle data to there just fine. I then thought I could import from an Access database instead of directly from Oracle. Well, that's not working either as the Access driver doesn't even show in my Data Source list, even though I can create an ODBC connection with it through the Control Panel.

My question is, where is this Data Source list coming from and does anyone have any suggestions as to what I can do next? I have already uninstalled and reinstalled SQL Server 2000 (client) on my NT box as well as Office 97.

Thank you.
sbuckingham
New Member
New Member

--
07 Jun 2005 05:15 AM
No, not yet. That's another story in itself! That box needs to be rebooted so I can get mouse control back. However, we have another non-production-type box with a copy of SQL Server on it and all the drivers I would expect are listed there. It seems to be local to me.
nosepicker
New Member
New Member

--
07 Jun 2005 06:53 AM
I've usually had good success using the "Microsoft ODBC Driver for Oracle" to connect directly to an Oracle DB. You should have a "Microsoft Access" option as well. If you don't have those, but you can make an ODBC connection (either with Oracle or Access), you should also be able to create an ODBC DSN and use it through "Other ODBC". Also make sure you have a recent version of MDAC installed (at least v2.7 I think).
sbuckingham
New Member
New Member

--
07 Jun 2005 07:05 AM
I, too, have had success with the "Microsoft ODBC Driver for Oracle" in the past, but now (since I have a different machine), whenever I push the Next button, nothing happens. In fact, it does not even appear that a connection is attempted.

As far as Access connectivity goes, I'm really confused as to why this driver does not appear in my Data Sources list even though I can setup an ODBC setting through Control Panel. Even when I do that, though, and I use "Other ODBC" as you suggest, the Next button does not move to the next window. I'm obviously missing something or did not install something correctly (BTW, I have MDAC 2.8 installed).

Right now, I'm trying to get my Access data into SQL Server using Access's Upsizer tool. But that gets me to SQL 7, not 2K (I received an Overflow error when I tried to go directly to 2K). What a roundabout way to do things!
sbuckingham
New Member
New Member

--
07 Jun 2005 09:43 AM
Yes, SP3 has been applied on my machine.
You are not authorized to post a reply.

Acceptable Use Policy