Transactional Replication Intial Snapshot Fails

Last Post 09 Jul 2004 02:40 PM by Mpp. 0 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Mpp
New Member
New Member

--
09 Jul 2004 02:40 PM
Hi,
I am implementing transactional on an environment where the size of the Publisher database is 300 GB and it has got more then 100 Articles. There is only one subscriber.

Server 1(Publisher) -> 8 GB RAM, 520 HDD, Pentium III Xeon, 500 MHz (4)
Server 2(Subscriber) -> 8 GB RAM, 520 HDD, Pentium III Xeon, 500 MHz (4)
Server 3(Distribution Shared Folder) -> 8 GB RAM, 520 HDD, Pentium III Xeon, 500 MHz (4)

I am facing below problems with the initial snapshot schema generation:
01. The schema generation process is huge (more then 24 hours) although we have around 100 Articles
02. After 24 hours of Schema generation, it gave me below error and all the files get deleted from the distribution shared folder;

ERROR: The process could not create file
\\Server\DistributionShare\unc\Srv_OLTP
Transactional\20040706050341\S_ACT_EMP_333.sch

The process cannot access the file because it is being used by another process….

The above error repeaded twice. Could anyone help me out on this?
- How do i able to have a complete initial snapshot sucessfully.
- Since the size of the Publication db is very high (300 GB), Is this feassible what I am currently doing
- Is there anyway I can preserve the schema files from DELITION if something bad happens in between

Looking forward for a response!

Thanks,
You are not authorized to post a reply.

Acceptable Use Policy