SP3 80sp3-tools.sql Error

Last Post 20 Apr 2010 06:27 PM by ARW. 2 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
Topic is locked
Author Messages
Shawn_SQL
New Member
New Member

--
26 Feb 2003 06:45 AM
I have a SQL 2000 server with windows 2000 OS that is having a problem when I install the SQL SP3. I get an error part way through the install that says:

Error running script: 80sp3-tools.sql(1)

I have looked at the SQLSP.Log file and the end of it has the following information.

07:06:34 Upgrading databases
07:06:34 Upgrading databases on instance 'MSSQLSERVER'
07:06:34 C:\DOCUME~1\sdavid\LOCALS~1\Temp\SqlSetup\Bin\scm.exe -Silent 1 -Action 6 -Service MSSQLSERVER
07:06:34 Process Exit Code: (0)
07:06:34 C:\DOCUME~1\sdavid\LOCALS~1\Temp\SqlSetup\Bin\scm.exe -Silent 1 -Action 6 -Service MSSQLSERVER
07:06:34 Process Exit Code: (0)
07:06:34 C:\DOCUME~1\sdavid\LOCALS~1\Temp\SqlSetup\Bin\scm.exe -Silent 1 -Action 1 -Service MSSQLSERVER -StartupOptions \-T4022 \-T4010 \-m
07:06:45 Process Exit Code: (0)
07:06:45 C:\sql2ksp3\x86\BINN\osql.exe -Slpc:WEB1 -b -n -d master -o "C:\Program Files\Microsoft SQL Server\MSSQL\install\sp2_serv_uni.out" -i "C:\Program Files\Microsoft SQL Server\MSSQL\install\sp2_serv_uni.sql" -Usa -P"
07:06:47 Process Exit Code: (0)
07:06:47 C:\sql2ksp3\x86\BINN\osql.exe -Slpc:WEB1 -b -n -d master -o "C:\Program Files\Microsoft SQL Server\MSSQL\install\80sp2-tools.out" -i "C:\Program Files\Microsoft SQL Server\MSSQL\install\80sp2-tools.sql" -Usa -P"
07:06:48 Process Exit Code: (0)
07:06:49 C:\sql2ksp3\x86\BINN\osql.exe -Slpc:WEB1 -b -n -d master -o "C:\Program Files\Microsoft SQL Server\MSSQL\install\sp3_serv_uni.out" -i "C:\Program Files\Microsoft SQL Server\MSSQL\install\sp3_serv_uni.sql" -Usa -P"
07:06:56 Process Exit Code: (0)
07:06:56 C:\sql2ksp3\x86\BINN\osql.exe -Slpc:WEB1 -b -n -d master -o "C:\Program Files\Microsoft SQL Server\MSSQL\install\80sp3-tools.out" -i "C:\Program Files\Microsoft SQL Server\MSSQL\install\80sp3-tools.sql" -Usa -P"
07:07:07 Process Exit Code: (1)
07:07:31 Error running script: 80sp3-tools.sql (1)
07:07:31 C:\DOCUME~1\sdavid\LOCALS~1\Temp\SqlSetup\Bin\scm.exe -Silent 1 -Action 6 -Service MSSQLSERVER
07:07:46 Process Exit Code: (0)
07:07:46 Action CleanUpInstall:
07:07:46 Installation Failed.

Has anyone seen this before? I am wondering if this could be related to a problem with single user mode during the install of the service pack? Any Ideas?
satya
New Member
New Member

--
26 Feb 2003 01:36 PM
Error running script: 80sp3-tools.sql (1)

Do check the server Network Utility and check the available enabled protocols. Try using Named Pipes only and perform the same for Client Network Utility on the Server.

Now reinstall the SP, if the install is okay, put TCP/IP and rest back for both Client and Server utility on the Server and test the connections.

Also have a read thru in SP3readme.html for troubleshooting.

HTH
ARW
New Member
New Member

--
20 Apr 2010 06:27 PM
Hi all, I´m late for this forum, but maybe this will help someone. In my case I ran the script manually and I Found that these objects didn´t have dbo ownership in MSDB database: RTblClassExtension table and r_iRTblClassExtension SP. I changed the ownership to dbo and I ran again "setup.bat" file and it works...
Topic is locked

Acceptable Use Policy