Report Viewer Control Authentication

Last Post 26 Oct 2005 12:39 PM by ChabotWVU. 0 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
ChabotWVU
New Member
New Member

--
26 Oct 2005 12:39 PM
I am having an authentication problem using the Report Viewer Control. The situation is that I have developed a simple ASP.NET application that will used as an interface for Report Viewing. First, I have a TreeView Control located on the default page that is being populated with the current reports that are published on the Report Server. Second, I have a aspx page called ReportViewer that holds the Report Viewer Control. Third, when a user clicks on one of the reports in the TreeView control the report is generated in an IFrame located in a table cell on the default page.

My Problem is that everytime I click to generate a report I am asked for windows credentials. I am passing the full network credentials(testing environment going to use an application pool when live and pass default credentials) example System.Net.NetworkCredential("username", "password", "domain") in the load event of both aspx pages and IIS directory security is setup with anonymous access & integrated windows authentication(I have tried about everything in IIS Directory Security). I have tried about everything and for the life of me cannot get around this issue any assistance would be greatly appreciated.

Thanks,

Andrew MCSA, MCDBA
You are not authorized to post a reply.

Acceptable Use Policy