Automatic login and manual login

Last Post 04 Oct 2004 12:17 AM by Craig HB. 4 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Craig HB
New Member
New Member

--
01 Oct 2004 08:56 AM
Hi

I am using Reporting Services to show reports in a Inventory Control asp.net
web app. So that users do not have to log into a windows account when they
want to see a report, I mapped the anonymous user to the windows user
"RSUser" (as in "Reporting Services User") in IIS. That way whoever uses the
web app is automatically logged in as RSUser.

This works well until we decided to use Report Manager as our reporting app
that will work together with the Inventory Control app. We wanted to be able
let users log in as themselves and have different access depending on who
they were, but they were automatically logged in as RSUser by IIS.

So, in IIS, I copied the 2 virtual directories that reporting services use
(Reports and ReportServer) from the Default Web Site to the Inventory Control
web site (both in IIS, on the same server). Both sets of virtual directories
are the same and point to the same actual directory (i.e. C:\Program
Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer). The
difference is that one under the default website does not allow anonymous
access (and so will prompt the user to login), and the other is under
Inventory Control web site and will automatically log the user in as RSUser.

Problem is : http://[Inventory Control Website]/ReportServer doesn't work.
you get "permission denied". If you allow directory browsing, you see the
files within the directory, not the report. it is as if reporting services
can't render a report if it is not accessed via the default virtual directory
(could this be so ?).

Any idea why this doesn't work or any better suggestions ?

Thanks,
Craig
Craig HB
New Member
New Member

--
04 Oct 2004 12:17 AM
Problem fixed. The 2 sets of virtual directories were not identical. When I corrected that, it worked.

Craig
plompd
New Member
New Member

--
28 Oct 2004 03:24 AM
Well for me it is not working.
I still have to fill in username and password.

My custom website uses port 80, and a HTTP HEADER. So I have multiple website that use the same IP number, but custom headers. I don't know if that could be a problem?

Hope you have some more tips for me...

Greetings,
Daniel
Craig HB
New Member
New Member

--
28 Oct 2004 03:39 AM
I'm afraid I don't because what I did worked, but here is where I noticed the difference in the 2 virtual directories. open the properties for the the virtual directory. on the virtual directory tab, click the configuration button. check there, especially under the mapping tab.

hope that helps,
Craig
plompd
New Member
New Member

--
28 Oct 2004 04:09 AM
So this RS Account, where can I find wich account is meant by that? If I use the anonymous user account from IIS then it is not working. Even an administrator account will not work. Still the same login screen.

Is there a place where I can find the information and the security settings of the Report Service?
You are not authorized to post a reply.

Acceptable Use Policy