Parameter problem

Last Post 26 Jul 2004 10:58 AM by xfonhe. 4 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
hw123456
New Member
New Member

--
22 Jun 2004 05:24 AM
Hi all,

I am trying to pass some parameter through URL. Here's what i did.
First I created a query with parameter, for example:

Select * from customer where id = @id

then before i load the page in asp.net i apply the code below
<code>
ReportViewer1.ServerUrl = "http://localhost/reportserver?/Report Project1/report1&rs:Command=Render&id=7"
<code>

An error has occur.
<error>
Reporting Services Error

An attempt was made to set a report parameter 'ID' that is not defined in this report. (rsUnknownReportParameter) Get Online Help
<error>

Is this the right way to pass parameter through URL...

Thanks,
Henry
oldtang
New Member
New Member

--
22 Jun 2004 11:13 PM
Dear Henny,

Try this.

http://tedtang/reportserver?%2fReport Project1%2fReport3&id=7&rs%3aCommand=Render&rs%3aFormat=MHTML
hw123456
New Member
New Member

--
23 Jun 2004 04:38 AM
Thanks oldTang!!!

It was solved!!!

I am a newbie in sql reporting services. I had another question, do u know how to create subreports.

Thanks,
Henry
oldtang
New Member
New Member

--
23 Jun 2004 03:03 PM
Do you mean Hyper Link report?
xfonhe
New Member
New Member

--
26 Jul 2004 10:58 AM
Subreports are a type of report regions... they appear in the Toolbox view in Report Designer.

Drag & drop the object into the layout tab.

NOTE: table & matrix data regions are preferable to subreports because they do not require multiple renders (a subreport, in essence, is actually two reports: the body of one report rendered and presented in the body of another report)
You are not authorized to post a reply.

Acceptable Use Policy