replmerg.exe

Last Post 12 Dec 2005 11:04 AM by muralikrishna. 1 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
muralikrishna
New Member
New Member

--
07 Dec 2005 08:26 AM
Hello All,

We have a replication system that is in place for a SQL Server 2000 server which works great. We are using SQL-DMO in a visual basic application to create publication and subscriptions. Now I have upgraded one of our test server to SQL Server 2005 and was able to publish data with our application with slight modifications for the SQL-DMO stuff (especially while looping though databases or tables or views collection, it fails to recognise for each condition). The was able to create subscription on both 2000 and 2005 server and was also able to create the merge jobs. 2000 subscription works normally, but when I try to execute the merge job on 2005 subscription, it fails with the following error.

-------------------------------------------------------------------------------------------
Date 11/30/2005 2:57:00 PM
Log Job History (TEST_Merge_Sync)

Step ID 6
Server TEST
Job Name TEST_Merge_Sync
Step Name Merge_TEST_PUBS
Duration 00:00:00
Sql Severity 0
Sql Message ID 0
Operator Emailed
Operator Net sent
Operator Paged
Retries Attempted 0

Message
The step is improperly defined and so could not be run. The step failed.
-------------------------------------------------------------------------------------------

But I am able to execute the same step with same conditions from command prompt. It works with out any errors.

Here is how my job is defined.

-Publisher TESTSERVER -PublisherDB TEST_PUBS -Publication TEST_PUBS -PublisherSecurityMode 0 -PublisherLogin sa -PublisherPassword password -DistributorSecurityMode 0 -DistributorLogin sa -DistributorPassword password -Distributor TESTSERVER -Subscriber TEST -SubscriberDB TEST_PUBS -SubscriptionType 1 -SubscriberSecurityMode 0 -SubscriberLogin sa -SubscriberPassword password -FileTransferType 0 -LoginTimeout 300 -QueryTimeout 600

I created a subscription manually on the 2005 server to the same publication, it works perfect. I am not sure what I am doing wrong. Can any one help me finding the problem. I tried to run SQL Trace but no luck over there.

How can I validate a publication and a subscription. How can I know if everything is set right and is supposed to work and what should I be looking for.

Thank you for all your help.

Murali.
muralikrishna
New Member
New Member

--
12 Dec 2005 11:04 AM
I am moving this issue to SQLServer 2005 Administration.
You are not authorized to post a reply.

Acceptable Use Policy