SQL SERVEr Linked Server Error: Error 7399 MSDAORA Error conecitng oracle 9i

Last Post 05 Sep 2005 02:39 AM by SQLORACLEUSER. 1 Replies.
AddThis - Bookmarking and Sharing Button Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
SQLORACLEUSER
New Member
New Member

--
02 Sep 2005 04:46 AM
Hi,

I have setup a linked server that intermittently crashes.

It connects to an Oracle 9i Database on an alternate server. My tnsnames.ora file is correct and the Linked server does periodically work....

I am not sure what triggers it but it crashes and gives the following error:

Error 7399: OLE DB provider 'MSDAORA' reported an error. The provider did not give any information about the error.
OLE DB error trace [OLE/DB Provider 'MSDAORA' IDBInitialize::Initialize returned 0x80004005: The provider did not give any information about the error.].

Can anyone help with this please ?

Which is the correct configuration in terms of drivers to use and vendor. Are there any registry settings that need changing?

I'm trying to connect to Oracle 9i database

Thanks,

Simon.
SQLORACLEUSER
New Member
New Member

--
05 Sep 2005 02:39 AM
Hi,

It is is setu with Microsoft OLE DB provider.

My TNS entry is "MSDAORA"

I'm passing these values for my Linked server:

Product name: MSDAORA
Provider name: Oracle
Data Source: MSDAORA
Provider String: oracle910

Is this correct? specifically my provider string ?


You are not authorized to post a reply.

Acceptable Use Policy