SQL Agent Service Login

Last Post 11 May 2012 06:00 AM by rm. 4 Replies.
AddThis - Bookmarking and Sharing Button
Author Messages Not Resolved
dstoltz
New Member
New Member

--
01 May 2012 06:59 AM
Hi All,

I have an instance of SQL 2008 R2, which is also running a bunch of SSIS jobs via the SQL Server Agent.

The SQL Agent Service is not running as local system account like it should be, it's running under a domain admin's network account.

I tried switching this service to run as local system account, but when I do (and restart the service) the agent jobs do not run. In SQL MGMT Studio the SQL Server Agent listing says: "agent xps disabled"

The service itself starts and runs fine with the local system account, but I'm not sure what to check - there must be something "tied into" the service that breaks...

Any suggestions?

Thanks!
gunneyk
New Member
New Member

--
10 May 2012 09:08 AM
The account that is running SQL Agent under needs to be a sa in SQL Server. It does not eed to be sa on the machine.
rm
New Member
New Member

--
10 May 2012 01:15 PM
You can enable 'agent xps' with sp_configure.
dstoltz
New Member
New Member

--
10 May 2012 01:28 PM
Yep, I know it can be enabled manually - I guess my concern was why is it disabled when I use the local system account and restart the service?....if I go back to my domain admin account and restart the service, its enabled by default...which leads me to believe I would get an error if I tried to enable it with sp_configure, but I haven't actually tried that yet.

rm
New Member
New Member

--
11 May 2012 06:00 AM
I had that and enabled with sp_configure without any issue. In my case, 'agent xps' had run value 1 but config value 0 so couldn't connect to sql agent in ssms even service was running. You may check sql agent error log if have any clue.


Acceptable Use Policy
---