Publication Does Not Exist

Last Post 11 Mar 2004 02:03 PM by Bull. 0 Replies.
AddThis - Bookmarking and Sharing Button
Author Messages
Bull
New Member
New Member

--
11 Mar 2004 02:03 PM
I am attempting to set up merge replication between two SQL Server 2000 instances over the internet. The publisher and distributor are the same server and it is not behind a firewall. The subscriber is behind a firewall which has ports 1433 and 1434 opened.

I have created a publication on the publisher and I have created an anonymous subscription on the subscriber. The subscription is successfully created, but when it attempts to apply the snapshot, the job step keeps failing with an error of "Publication <publication name> does not exist." The job is able to connect to the publisher and distributor as the first two parts of the step, but fails when trying to get the publication. However, the publication clearly exists, and I can get it through SQLDMO code by logging to the publisher and enumerating the publication with its name and other properties. Yet, the job keeps failing saying the publication does not exist.

The publication is enabled for the internet. I have both to use an alternate snapshot location on the subscriber to simulate it being on a CD (which is ultimately what we need to do for the customers involved) and tried it with the FTP download.

I have wondered about the publication name and if it needs to be qualified in some way. I have tried numerous approaches to this, for example:
<instance name>:<publisher DB>:<publication name> and <publisher DB>:<publication name>: I have also dots to separate the objects, and exclamation marks. When the subscription is created, the merge agent clearly shows only the <publication name> in the job step "-Publication [<subscription name>]."

I have tried the above numerous times using the enterprise manager and through SQLDMO code. The subscription is always created, but fails in the job step when it comes to the publication.

I am sure I am missing something simple, but I cannot figure out what it might be. I have also searched many web sites and Microsoft and the only thing I find on relates to SQL Server 7.0 and their case is nowhere close to the problem I am having.

Any help or ideas would be greatly appreciated.

Bull


Acceptable Use Policy
---