SQL2k5 HA & SSIS

Last Post 13 Feb 2008 05:41 AM by darknessrockson. 8 Replies.
AddThis - Bookmarking and Sharing Button
Author Messages
darknessrockson
New Member
New Member

--
04 Feb 2008 09:00 AM
ISSUE:
I have SQL2k5 installed on a High Availabilty cluster and have SSIS and SSRS on a third and non-clustered server. I copy the package to the DB instance create a job, and execute said job, I receive the following error:

"Executed as user: DOMAIN\srvaccount. Microsoft (R) SQL Server Execute Package Utility Version 9.00.3042.00 for 64-bit Copyright (C) Microsoft Corp 1984-2005. All rights reserved. Started: 8:42:32 AM Error: 2008-02-01 08:42:32.77 Code: 0xC0012024 Source: Script Task Description: The task "Script Task" cannot run on this edition of Integration Services. It requires a higher level edition. End Error DTExec: The package execution returned DTSER_FAILURE (1). Started: 8:42:32 AM Finished: 8:42:32 AM Elapsed: 0.156 seconds. The package execution failed. The step failed."

Now if I login as local admin to the SSIS server, and open Mgmt studio and execute the package it works fine. How do you a) schedule packages to execute, b) set security so that it can execute?

Or is there another work around that someone has come accross?

Michael
SQLUSA
New Member
New Member

--
04 Feb 2008 04:37 PM
Michael,

When you say you copy package,

do you mean, you DEPLOY the package and INSTALL it at destination?

Kalman Toth - Database, Data Warehouse & Business Intelligence Architect
SQLUSA: http://www.sqlusa.com/order2005repo...gservices/ The Best SQL Server 2005 Training in the World!
darknessrockson
New Member
New Member

--
05 Feb 2008 05:47 AM
Correct it is deployed to the server using bids/vs2k5. --Michael
darknessrockson
New Member
New Member

--
05 Feb 2008 05:55 AM
Same edition, used same CD's, Same OS level/patch. --Michael
darknessrockson
New Member
New Member

--
05 Feb 2008 10:54 AM
Yes, Sp1. no minor fix updates. I am planning on updating to SP2 this weekend just to get everything up to current before I place a MS call.

Michael
darknessrockson
New Member
New Member

--
12 Feb 2008 06:59 AM
Ok I went and upgraded everything to Sql2k5 sp2. Now the versions are:

9.0.3054 - ssis server
9.0.3042 - database server

Executing the Maintenance plan and the job still gets the same error results.

Suggestions?

--Michael
darknessrockson
New Member
New Member

--
13 Feb 2008 05:41 AM
NO neither node has SSIS installed.
darknessrockson
New Member
New Member

--
13 Feb 2008 11:28 AM
Ok I am confused, Since it is not a cluster aware service microsoft doesn't support SSIS in failover clustering (Documented but NOT Supported). In the white papers they suggest running non clusterable services out side of the cluster on a separate host. But you can't manage the services with out locally managing it on the host (Double-hop authentication issue), so change the xml file and schedule the job rather than activated it throug ssis snapin. But that doesn't work because ssis needs to be installed on the nodes for the agent to execute the jobs?

So basically it looks like I need to do the non recommended microsoft process and install ssis?
SQLUSA
New Member
New Member

--
13 Feb 2008 12:41 PM
>schedule the job rather than activated it throug ssis snapin. But that doesn't work because ssis needs to be installed on the nodes for the agent to execute the jobs?


Yes. SSIS is a server service. If you don't have it, or you stop it, you cannot execute SSIS packages.

Kalman Toth - Database, Data Warehouse & Business Intelligence Architect
SQLUSA: http://www.sqlusa.com/BI2005WorkShop/ The Best SQL Server 2005 Training in the World!


Acceptable Use Policy
---