How can I recreate this mysterious error?

Last Post 10 Jan 2008 11:29 AM by HarryNejad. 0 Replies.
AddThis - Bookmarking and Sharing Button
Author Messages
New Member
New Member

10 Jan 2008 11:29 AM

One of our clients has reported that when they run the application and click a button they get this error:

Invalid character value for cast specification

They get this error only between 11:00 AM and 3:30 PM.
They do NOT get it at other times!!!

The code behind it is quite simple.
It is a call to a stored procedure with 11 input parameters and one output parameter
The output parameter is int
The input ones are diverse: int, datetime and varchar.

When I run the query in QA, I can NEVER get this error.
When I run the query in the application, again, I can NEVER get this error.
When I run the query in the application dev. environment, step by step, again, I can NEVER get this error.

Even when I pass wrong values deliberately, STILL I cannot get this error.
The worst case is that if I pass totally wrong values (for example gibberish for the date or integer parameters) I get a DIFFERENT error:

Application uses a value of the wrong type for the current operation


Error converting data type varchar to datetime

But I cannot reproduce the error that our client gets in their site.

What could the cause of this error be?
How can I reproduce it?
How can I resolve it?

Please note that the application is VB6 and the connection is via SQLOLEDB

Any help with this is greatly appreciated.



Acceptable Use Policy