Enable Named Pipes on Windows XP Professional PC

Last Post 23 Feb 2009 01:27 PM by hmbtx. 0 Replies.
AddThis - Bookmarking and Sharing Button
Author Messages
hmbtx
New Member
New Member

--
23 Feb 2009 01:27 PM
On my server the following query gives me the Database Name followed by the Computer Name and NT User Name that has a database opened.

select sysdatabases.name,sysprocesses.hostname,sysprocesses.nt_username
from sysprocesses
inner join sysdatabases
on sysprocesses.dbid=sysdatabases.dbid
where sysprocesses.hostname <> '' and sysdatabases.name like 'Membership%'
order by sysprocesses.hostname

My server is using Mixed authentication. On the Server in Network Client Utilities, under the General Tab, Enabled protocols by order: Named Pipes, TCP/IP. Under the Network Libraries Tab, Names Pipes is first followed by TCP/IP.

When you run the query above some rows return the nt_username and shows Names Pipes as the net_library and other rows that DO NOTreturn the nt_username shows TCP/IP as the net_library.

All users of the MSSQL 2000 databases which are located on the server are PC’s connected via the network.

The PC’s are NOT connecting to the database via an ODBC driver. They are using a third party program located on the server which connects via the native MSSQL drivers.

The only thing that I install on the PC’s is a desktop icon which runs a program on the server that connects to the database on the server.

My question is this. Why are some PC’s connecting using Named Pipes and some using TCPIP?

It appears that it has something to do with configuration of each PC although they do NOT use the ODBC driver and MSSQL is not installed on the PC.

Thanks
Howard


Acceptable Use Policy
---