(rsErrorOpeningConnection) Could not obtain information about Windows NT...

Last Post 07 Dec 2009 08:23 PM by amcintyre. 0 Replies.
AddThis - Bookmarking and Sharing Button
Author Messages
amcintyre
New Member
New Member

--
07 Dec 2009 08:23 PM
I am trying to deploy a report to the Reporting Services Server but keep running up against this error:

quote:

An error occurred during client rendering.
An error has occurred during report processing. (rsProcessingAborted)
Cannot create a connection to data source 'dataSource1'. (rsErrorOpeningConnection)
Could not obtain information about Windows NT group/user 'DOMAIN\useradmin', error code 0x5.


Here’s my situation: Everything is being ran using DOMAIN\useradmin and the report is using a remote database.

Reporting Services and SQL Server are both ran under DOMAIN\useradmin. DOMAIN\useradmin is a windows AD login and is part of the server machine Administrators group.

My test report is using a data source model that in turn is using a data source that is connection to a database on a different SQL Server. The data source is using “Credentials stored securely in the report server” with the options “Use as Windows credentials when connecting to the data source” and “Impersonate the authenticated user after a connection has been made to the data source.”

I am using the credentials of DOMAIN\useradmin that is the db owner of the remote database.

DOMAIN\useradmin is assigned the roles, System Administrator, System User and Browser, Content Manager, My Reports, Publisher, Report Builder.

So if everything is being run under an über AD account, why I am getting this Could not obtain information about Windows NT group/user 'DOMAIN\useradmin' error?

Under normal circumstances , an AD login with Publisher permissions will developing reports using a datasource model created by DOMAIN\useradmin but using one of the remote database’s users which is mapped from yet another AD login.


Acceptable Use Policy
---